WordPress 2.7へアップグレード

WordPress | 日本語 ≫ WordPress 2.7 日本語版リリースのお知らせ

2.7の日本語版が出たようなのでアップグレードしました。

特に問題なくアップグレードできたように見えたのですが一つ問題が。
ダッシュボードに

Warning: Attempt to assign property of non-object in
うんたら~/wp-includes/rss.php

のようなエラーが。

実は前にもこのエラーが出て修正したのですがアップグレードで上書きされてしまったのでした。
そこでWordPress ? Support ≫ rss.php problemsを参考にrss.phpの

if ( isset($rss) and $rss ) {

//if ( isset($rss) and $rss ) {
if ( isset($rss) && (is_object($rss) ||(is_string($rss) && $rss=unserialize($rss))) ) {

へ置き換え、無事正常に表示されました。

またあったときのためにメモ。

※追記
まだ間違えて上書きしたのがあったw
AutoPagerize用のwp-includesの中のlink-template.php。
適当に

return ‘<a href=”‘ . next_posts( $max_page, false )

return ‘<a rel=”next” href=”‘ . next_posts( $max_page, false )

へ変更。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です